MikkiLL Show full post »
scott2326
I did actually speak to Troy about it briefly so yes it was most likely me. I've had the same issue with both screens i have.
 I also had an issue yesteredy with i7, all 3 screens i tried took a very long time to boot up, once they did the touch would work for one action then freeze up then work again for one click and freeze up. This was on a pre updated ios 11. When tested on one with 10.3 they worked fine. :/
Quote 0 0
Steve
It was indeed Troy who mentioned this to me.

Have you tried the old trick of using OEM to update and trying the screens after (if possible) - this may well confirm if it is the update causing the issue or not.

Saying that we had 2 iPhone 7s in for repair today, aftermarket screens fitted on both and all was good - we did however update both to 11 before carrying out the repair. 
Steve Garner | Replacebase Founder 

Need support? my team are happy to help - sales@replacebase.co.uk | 01604924700
Quote 0 0
scott2326
Both devices came in already updated before the repair. I no longer have then here to play with unfortunately. Ill have to wait and try with a new OEM screen and cross my fingers. 
Quote 0 0
MikkiLL
7/7+ will work if everything is fitted - home button and sensor flex - if not, you'll get stuck at Apple logo. I mentioned this before, but no one listened.. They "reinstated" error 53 without calling it so.. If you haven't got the original home button, it won't start as well..
Quote 0 0
scott2326
MikkiLL wrote:
7/7+ will work if everything is fitted - home button and sensor flex - if not, you'll get stuck at Apple logo. I mentioned this before, but no one listened.. They "reinstated" error 53 without calling it so.. If you haven't got the original home button, it won't start as well..


All parts were fitted to new screen and are working 
Quote 0 0
scott2326
I've fitted a new OEM screen form replacebase. Original home button, it took about 3/4 mins too boot up asn it very slow to the touch. ill press the phne app and it will take 20 seconds to respond. Any solutions?
Quote 0 0
Crea2k
What phone have you got ?, does it work ok with the original screen ?. As laggy touch on the 7 is a symtom of a problem with the audio ic where one of the pads to the cpu gets high resistance And causes laggy touch.
Quote 0 0
Andy @ ACE-Repairs
Ive had a weird 1 today.  iPhone 6S came in for a screen.  Origianl screen dead & disabled itself. fitted new aftermarket screen and restored it on itunes.  All fine inc touch, no icloud details so gave back to customer as untested.  They returned with it next day saying no touch, I put in recovery mode and restored it.  Touch working fine, I inputted icloud details and loaded a backup, once complete no touch.  Weird.  Not had chance to invesigate yet.
Quote 0 0
Steve
Good news guys!

3572822.jpg 
Steve Garner | Replacebase Founder 

Need support? my team are happy to help - sales@replacebase.co.uk | 01604924700
Quote 0 0
Andy @ ACE-Repairs
11.0.3 sorted me out, great news.
Quote 0 0
Jay
replacebase wrote:
Good news guys!

3572822.jpg 


Apple showing that they can make phones stop working at the drop of a hat.

obviously realised that they would have more lawsuits on their hands, they really don't like third party repairers do they.

glad they released an update though.
Quote 0 0

Would you like us to send you notifications about discount codes, news and offers?

Remind me later

Thank you! Please check your email inbox to confirm.

Oops! Notifications are disabled.