Damtom
Hi . Just got iphone 7. 

Lady says it discharged till 0% , shut down and she wasn't able to charge it. 

What i checked so far , no reaction to charger. Battery connector shows 0V, if it is the same way like in previous iphones, one positive and negative tip. 

Anyone can suggest anything what to look for , before I start further work tomorrow. My next step is to check voltage on mainboard battery connector then to check lighting port up to flex connector , then charging IC . It would be nice if someone could share any schematics or pinout. Thanks
Quote 0 0
Damtom
Follow up

Mainboard is getting 5V from charger. 
Mainboard connector to battery there is only 0.2V . 

Suspected U2 charging IC damaged. 

I used my bench power supply(farnell L30DT) and connected to battery connector, set to 3.8V . Iphone is starting , apple logo visible , current drawn 0.3A, after 10-15 seconds current raising to 0.5A and iphone switching off . 

Should iphone start with power supply connected or if U2 IC is faulty it won't start ? 
Quote 0 0
iTechRepairs.ie
Sounds like the charging IC.
Quote 0 0
Damtom
Anyone interested to replace that IC , please send quotes 
Quote 0 0
iTechRepairs.ie
Damtom wrote:
Anyone interested to replace that IC , please send quotes 

We charge €50 to do it, but you'll have to send it over to us. We're based in Ireland.
Quote 0 0

Would you like us to send you notifications about discount codes, news and offers?

Remind me later

Thank you! Please check your email inbox to confirm.

Oops! Notifications are disabled.