BriG1
Hi all, My iPhone 6s rear camera and torch/flash have stopped working due to a little bit of water damage. I have googled the issue and found out that it is very likely the power chip for these items. Anyone know a good online repair company who would fix this for a reasonable price? 
Quote 0 0
Bytesize
BriG1 wrote:
Hi all, My iPhone 6s rear camera and torch/flash have stopped working due to a little bit of water damage. I have googled the issue and found out that it is very likely the power chip for these items. Anyone know a good online repair company who would fix this for a reasonable price? 


I love the "little bit of water damage" a little bit of water can do a hell  of a lot of damage, have you had the shields off to see what else may be corroded, I cam certainly take a look although I don't really do liquid damage repair for the sake of the phone
Quote 0 0
BriG1
Yes I not that but this is 'little'. I have had it apart and cleaned it with alcohol and there was only very slight corrosion around the camera connector. Everything else is working 100%.
Quote 0 0
Bytesize
Cool
Quote 0 0
Crea2k
Does the rear camera work ?, I'm going to hazard a guess and say probably not, as if the camera dies it generally stops the flash working too.
if you've cleaned up all visible corrosion (the most you can really do withou an ultrasonic cleaner) , try fitting a new rear camera (if not working). If the rear camera is working try a new power button cable, this has the flash module on it. If neither of these solve your problem you've damaged either a descrete component such as a ferrite or the camera pmu or possibly the flash control / pmu ic under the cpu shield (pain in the ass to change because it's caked in underfill).
Quote 0 0
BriG1
Hi, many thanks for your suggestions. Yes the camera does not work but I may have jumped to the conclusion to quickly when I googled it and found what looked like my exact problem which said that it was the power chip which supplies both camera and flash. I will get another camera and try it. Fingers crossed.
Quote 0 0
Crea2k
Usually if the camera pmu is faulty it'll stop front and back both working. My bet is on the camera being faulty and stopping the flash working. It's also possible that the flash on the power flex has died and is stopping the camera working, but Iv seen dead cameras more than Iv seen dead flashes, but with water damage it can be either or both, but mostly it kills the camera.
Quote 0 0
Andy @ ACE-Repairs
I second the above Crea2K post, if its the LDO IC (Camera IC) thats at top of the circuit board these control both cameras so normally if this is faulty both cameras shouldnt work.  Ive only ever seen 1 of these damaged by water, seen hundreds of rear cameras damaged tho.  1st try a new rear cam.
Quote 1 0
BriG1
Thanks for your help much appreciated.
Quote 0 0

Would you like us to send you notifications about discount codes, news and offers?

Remind me later

Thank you! Please check your email inbox to confirm.

Oops! Notifications are disabled.