scott2326
Iv'e recently replaced and ipad mini digitiser. Not the first time, probably near the 100th mark. Any way now the Power button is not responding to lock and unlock screen. Occasionally if i hold it long enough it will attempt to power down. Some  times not. 

I assumed may the flex was damaged so ive tried another, Worked ok for a few clicks then the same occurred. Also if i power it off if will turn back on as if its being pressed? 

Ive checked the connector on the board and it looks okay.

Any one have any ideas do the cause?
Quote 0 0
Bytesize
did you try another screen, sometimes if the digitiser ic is not soldered properly or more often than not I find it's the home button flex at fault.
Quote 0 0
FBG
As bytesize said its more than likely the screen. Iv had this problem a few times, button will work to turn the unit on and off but not to lock or unlock the scree.
Quote 0 0

Would you like us to send you notifications about discount codes, news and offers?

Remind me later

Thank you! Please check your email inbox to confirm.

Oops! Notifications are disabled.