BriG1
My iPhone 6 will not connect to the internet when on 3G. BT say my APN settings are wrong (BT-C 27.0) and should read 18.1. I have updated the carrier settings but they will not change to the correct settings. I just get the message that I am not subscribed to an internet service when I try to log on to the internet. Anyone any ideas what I can do? Thanks, Brian
Quote 0 0
TheMicroGuys
Have you tried going to [settings][general][reset][reset network settings]
The Micro Guys Ltd
WEB   http://www.themicroguys.co.uk
EMAIL service@themicroguys.co.uk
TEL    01803 467 477
Quote 0 0
BriG1
Hi, thanks for your message but yes I've done that a few times but it will still not change to the correct settings. Phone works perfectly in every other way. I'm baffled.
Quote 0 0
TheMicroGuys
Check time and date are correct on the phone.
Do you know the history of the phone. Has it had any repairs carried out? Are there any signs of bending especially around the sim tray area?
Also can you try the sim card in another phone just to confirm it isn't a duff sim card?
Are you on latest ios release? Maybe worth factory restoring and updating if necesssary. Do the restore/upgrade without sim card in the phone.
None of this may help, but these are some of the things I would try before delving any further 
The Micro Guys Ltd
WEB   http://www.themicroguys.co.uk
EMAIL service@themicroguys.co.uk
TEL    01803 467 477
Quote 0 0
BriG1
Many thanks guys. I will give your suggestions a try regarding the SIM card and the update with the sim out. It is one that I bought and replaced a broken screen on. One of many over the years but never had this issue before. Much appreciated. Brian
Quote 0 0

Would you like us to send you notifications about discount codes, news and offers?

Remind me later

Thank you! Please check your email inbox to confirm.

Oops! Notifications are disabled.